Installing VMware vSphere CLI for Linux x86_64

April 21st, 2012 | Posted by spritian in Linux | VMware

Pretty easy, but does need some requirements. You have to be root; Installing via sudo won’t keep the export variables listed below:


sudo su -
cd /root
apt-get install perl-doc libssl-dev libxml-libxml-perl
tar -zxvf VMware-vSphere-CLI-5.0.0-422456.x86_64.tar.gz
cd /root/vmware-vsphere-cli-distrib
export http_proxy=""
export ftp_proxy=""
./vmware-install.pl

You can follow any responses to this entry through the RSS 2.0 You can leave a response, or trackback.

2 Responses

  • Elaine says:

    Interesting^^

  • On Debian I got this:

    sh: 1: rpm: not found
    Openssl-devel is not installed on the system.
    openssl-devel 0.9.7 is required for encrypted connections.
    Please install openssl-devel version 0.9.7 or greater.

    sh: 1: rpm: not found
    e2fsprogs is not installed on the system

    e2fsprogs 1.38 is required for UUID.
    Please install e2fsprogs 1.38 or greater.



Leave a Reply

Your email address will not be published. Required fields are marked *

*